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1. Overview 

Before you start using the sound level meter, please read the instructions in this manual carefully. This 

overview section provides a brief summary of the steps involved in setting up your device for data 

recording (data logging), and how to download the data from the device to your computer. 

 

1. Open the battery cover at the backside of the meter and install a fresh 9V battery. If the battery is 

already installed and the device has previously been used, it will be difficult for you to estimate if the 

remaining battery life will be enough to support your recording session. If in doubt, power the meter 

through its USB port with the included data cable connected to a standard USB power adapter that 

converts outlet power to 5V USB (not included). Also see eS528L User Manual. 

2. Install the Smart Logger software (see section 2 of this software manual).  

3. Connect the sound level meter to a USB port of your PC using the included cable. The computer will 

detect the device and install the hardware driver. 

4. Double click the Smart Logger shortcut icon on your desktop to launch the software. 

5. Follow the steps below to set up the device and start recording (see section 4 of this software manual): 

- Name your data logger 

- Select the appropriate start mode (button, after setup, or timing) 

- Select sampling points and sampling rate 

- Click the Setup button to program your meter with the new settings 

6. Unplug the device from your computer. Place it at the location where you want to measure and record 

sound level data. 

7. If you selected “After Setup” as start mode during setup, your sound level meter is already recording 

data at this point. If you selected “By Button”, you need to press the “REC” button on the meter to start 

recording. 

8. To download data, reconnect the device to your computer’s USB port. Wait until the icon to the left of 

your device in the Device List changes from a red X to a green checkmark. Then press the green 

download button in the toolbar, or select “Instrument” -> “Download” from the menu. See section 5 of 

this manual for more details. 

9. After data has been downloaded, you can review it as a graph, data table, or summary report. See 

sections 6 through 9 for more details. 
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2. Software Installation 

1. The ennoLogic Smart Logger software supports Windows XP, Windows 2000 and 2003, Windows 

7, 8, and 10 for both 32-bit and 64-bit operating systems. At least 78MB of hard disk space and 

512MB of RAM are required. Only Windows based computers are supported at this time. 

2. Insert the software CD that came with your product into your computer’s CD drive or download 

the software at the ennoLogic website using this direct link. The version on the website may be a 

later version than the one on your CD. 

3. If installing from CD, go to the CD-ROM directory on your computer and double click the 

installation file "setup.exe" to install it. If using a downloaded version of the software, extract 

(unzip) the downloaded file first, it will contain one file: setup.exe. Double click on setup.exe after 

extracting it from the zip file. 

4. Follow the instructions displayed by the dialog boxes. Make sure to select the installation directory 

where you want the software to be installed. If you want to be able to share access to the program 

with non-admin users on your computer, please download version 2020.11.20.0942 of this software 

from the ennoLogic website using this link and install it on a drive other than C:/ Make sure to 

uninstall any previous version of the software first and then restart your computer before 

installing the new version, otherwise you may not be given the option to choose your installation 

directory. 

5. Select whether you want to create a shortcut (recommended). 

6. Select whether you want to launch the software immediately. 

 

Depending on your operating system, a suitable USB driver for the sound level meter will be 

installed automatically when the device is plugged into the USB port, and installing a USB driver 

manually should not be needed. If your computer has trouble installing a driver for the sound level 

meter in Windows versions other than Windows 10, please download the following driver and 

install it separately: https://ennologic.com/downloads/USBBridgeSetup_CA.zip. Unzip the 

downloaded file, then double click on USBBridgeSetup_CA.exe to run the installer. When asked to 

select the product type, choose “USB to UART Bridge” and click “Next”. Choose an installation 

directory (the default provided is usually fine), click “Next” and then “Install”. Click “Finish” to exit 

the setup. Plug in the sound level meter and check if the USB initialization succeeds. If Windows 

encounters a problem installing the “Holtek USB to UART Bridge” driver and says "A problem was 

encountered while attempting to add the driver to the store.", you need to disable Driver Signature 

Verification Enforcement on your computer since this driver is not digitally signed. To do that, 

please follow the instructions in this video: https://www.youtube.com/watch?v=71YAIw7_-kg. After 

https://ennologic.com/downloads/ennoLogic%20Smart%20Logger%20Software.zip
https://ennologic.com/downloads/ennoLogic%20Smart%20Logger%20Software.zip
https://ennologic.com/downloads/USBBridgeSetup_CA.zip
https://www.youtube.com/watch?v=71YAIw7_-kg


4 

you disabled driver signature enforcement, plug in the sound level meter again and this time the 

driver installation should succeed. Please note that these step should only be necessary in Windows 

versions other than Windows 10. 

7. Start the software using the shortcut icon that was placed on the desktop. If you chose not to create 

a shortcut, you may start the software by opening the file “SmartLogger.exe” in the “Smart 

Logger” directory. 

3. Software Interface and Menu 

 

 

Menu bar: Main menu items from left to right are "File", "Instrument", "View", "Options" and "Help." There 

are drop-down submenus below each main menu item. These functions are introduced in the table below. 

Toolbar: The toolbar provides quick access to frequently used functions. The icons of the toolbar represent 

the following functions (from left to right): "Download Data", "Open File", "Save File", "Print", "Device 

Settings", "Zoom" and "Reset Chart". 

Device list: Lists the devices which have been added to the system in a hierarchical tree.   

Graph and data display area: includes the tabs "Data Graph", "Data Summary", "Data List" and “Report”. 

Status bar: Indicates the selected data logger connection status. 

Functions of Drop-Down Submenus:   

No. Menu Functions 

1 File - > Open Open a data record (.rec) file for display 

2 File - > Save as Save the currently opened file as a txt, pdf or csv 

file (numeric data only, no graph) 

3 File - > Export to Excel Export the currently opened file to Excel file 

format  

4 File - > Close Close the currently opened file 
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5 File - > Print Print the currently opened graph or data list 

6 File - > Recent File List of recently opened files 

7 File - > Exit Exit the Smart Logger program 

8 Instrument - > Download Download data from device 

9 Instrument - > Device Settings Set up the device 

10 Instrument - > Device Management -> 

Add device 

Add new devices to system 

11 Instrument - > Device Management -> 

Remove device 

Remove devices from system 

12 View - > Toolbar - > Common Add/Remove common function toolbar buttons 

13 View - > Toolbar - > Plot Ctrls Add/Remove graph control toolbar buttons 

14 View - > Status bar Show/Hide the Status bar 

15 View - > Zoom Zoom graph 

16 View - > Reset Chart Reset the graph to its initial status 

17 View - > Background -> White Set data graph background color to white 

18 View - > Background -> Black Set data graph background color to black 

19 View - > Grid -> X-axis Show/Hide X-axis grid on graph 

20 View - > Grid -> Y-axis Show/Hide Y-axis grid on graph 

21 Options -> Comm Port Setup Communication port settings 

22 Options -> System Settings Optional settings (line colors, download directory) 

23 Options -> Calibration Adjustment Calibration settings, not accessible to user 

24 Options -> Real Time Monitoring Shows current decibel data updated in real-time 

25 Help -> User Manual Link to eS528L User Manual at ennoLogic website 

26 Help -> About Software version and copyright information 

27 Help -> Website Link to ennologic website 

 

4. Device Settings 

In the device list window on the left, click on the name of the device you want to setup to highlight it, even 

if you only have one device listed there. Then click the  icon on the toolbar, or choose the menu 

command "Instrument" -> "Device Settings" to enter the device settings interface. 

The Settings dialog box is shown below, followed by descriptions for each field. 
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Parameters Description 

Current Time You can manually set the date and time that is used for logging data. By 

default, the system date and time (from your computer) is used. 

Use System Time If checked, the data logger will use the system date and time, displayed by 

“Current Time”. Uncheck it to set the date and time manually. 

Logger Name Use this field to give your device a name that is easy to remember. 

Particularly useful when managing multiple devices. 

Work Mode Select “Recording” if you want the device to log data according to your 

settings (sampling rate, sampling points and start mode). If you select 

“Only Real-time Monitoring”, the device will only display real-time 

readings, but not record data. 

Sampling Points Specify the total number of sampling data points to be recorded. When 

the set number of samples has been reached, the device will stop 

recording automatically. Choose “Unlimited” to use the entire memory of 

32,000 data points. 

Sampling Rate  Set the sampling rate used for recording (how often a sample is recorded 

to memory). Available options are 1s, 2s, 5s, 10s, 20s, 30s, 1min, 2min, 

5min, 10min, 30min, 1hr, 2hr, 6hr, 12hr, 24hr 

Recording Time The software will calculate the total recording time automatically based 

on the selected sampling rate and sampling points. Make sure it is greater 

than your desired duration of data recording. 

Start Mode There are three ways you can start recording: By Button press, After Setup 

and Timing Start. When the Start Mode is set to "By Button”, recording 

can be started by briefly pressing the “REC” button on the device. If 

“After Setup” is chosen, recording will start automatically as soon as the 

settings have been sent to the device. “Timing Start” allows you to set a 

time in the future at which recording will start. 
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Time for Start If you selected “Timing Start” as Start Mode (see above), you can use this 

field to specify the time when data recording is to be started. 

Alarm Low Level and 

High Level 

These fields allow you to specify a low and high “alarm” sound level. The 

eS528L does not have the ability to sound or display an alarm when these 

levels are hit, but you will be able to see them in the graph of downloaded 

data as horizontal lines, making it easy to visually detect whether a 

decibel threshold of interest has been exceeded. 

 

Click the “Setup” button to send the settings to the device. If the meter received and processed them 

successfully, the following dialog box will pop up. 

 

 

If not, the following dialog box will pop up. In that case, please try again. If you continue to see “Setting 

failed” after pressing the “Setup” button, please try using another USB port, ideally the one you used when 

initializing the meter for the first time. 

 

 

Click the “Default” button to return all settings to factory defaults.  

Click the “Cancel” button to abort the device setup process. 

 

Warnings: 

1）When setting up the device, any data stored in the data logger will be permanently erased. To ensure 

any previously recorded data is not lost, please download and save the data first. Click the "Cancel" button 

to close the setup dialog and return to the main window. Then click the green download icon to retrieve any 

data still stored in the device.  

2）The data logger will stop working if it runs out of battery power. Use a fresh battery for longer 

recordings. Or power the device with a standard USB power adapter (not included) and the included USB 

data cable. If the device is powered through the USB port, the internal 9V battery will not be used. 
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5. Downloading Data to your Computer 

Follow these steps to download the stored data from you device to your computer: 

     1） Plug the data logger into a USB port on your computer. 

     2） Open the Smart Logger software if it’s not already running. 

3)  In the device list window on the left, click on the name of the data logger you want to download 

data from, even if you only have one device listed there. 

     4） Click the  icon on the toolbar or select the menu command “Instrument” -> “Download”. 

     5） The following dialog box will appear. Click the "Download" button to start downloading data 

from the device. 

 

If there is no data stored in the device yet, the following message will appear:   

 

Otherwise, data download will start, a progress bar will appear, and when all data has been 

downloaded a message will be displayed.  

   ->   

Click on the “View” button to display the downloaded data in a graph (see next section for details).  

Or click on “Cancel” to return to the main window. The downloaded data will still be saved as *.rec file. The 

name of the file will automatically be generated from the date and time of the data download. It will be 

placed in a folder with the name of your device. 
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6. Data Graph 

The data graph displays the downloaded sound level data (decibels) over time. 

 

You can change the color of the curve, show or hide the high and low alarm levels that were specified 

during setup and show a tooltip to display the numeric data as you hover the cursor over a point on the 

graph. Using the menu, select "Options -> System Settings".  

 

 

Check the box “Show Tip” to see numeric data as you hover the cursor over a point on the graph. Enable 

“High Low Alarm Line” to show the high and low alarm levels that you specified at setup as dotted 

horizontal lines. You can also change the color of the data curve. The eS528L only has one channel (Channel 

0). Ignore the “Dew Point Temperature” checkbox, this option is not used for this device. 

Using the same dialog, you can also change the directory the downloaded files are stored in, or change the 

language and time format. 

 

You can also customize the chart window. To change the background color from white to black, choose 

menu item “View” -> “Background” -> “Black”. To turn on a grid for the X and Y axes, select “View” -> 

“Grid” -> “X-axis” and/or “View” -> “Grid” -> “Y-axis”. 
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To zoom into a section of the graph, click on the blue crosshair icon in the toolbar, or select menu item 

“View” -> “Zoom”. Then use the mouse wheel to zoom in or out. After zooming in, you can pan the graph 

by pressing the left mouse button and dragging the graph window to the left or right. 

 

 

 

To reset the graph to its fully zoomed-out state, select “View” -> “Reset Chart”. 

7. Data Summary 

The "Data Summary" tab provides a quick overview of the collected data record, including the number of 

records (data points), start and end time, maximum, minimum and average values, and the difference 

between maximum and minimum. 
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8. Data List 

The "Data List" tab displays the downloaded data in a table. You can select a time range to display only a 

portion of the data, and also export the data to a CSV or Excel file. 

 

9. Report 

The "Report" tab generates a summary of the downloaded data that can be exported as a pdf file. It includes 

device information, summary data, data graph, and a table of all numeric data. 
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10. Troubleshooting and FAQs 

 

Q: I'm having trouble with the setup step. When I click "Setup" a prompt pops up that says 

"Setting failed, please try again!" I tried again several times, but the setup procedure keeps 

failing. 

 

A: In this case, the software is not able to communicate with the sound level meter through the USB port. 

First, we have to make sure the software has detected the sound level meter and added it to its list of known 

devices. Launch the software first, without the meter connected to the USB port. After the software is 

running, connect the meter. A few seconds later, the software should pop up with a message saying that it 

detected a new device, click "OK", give it a name, and click "Add": 

 

 

If you don't see it pop up with this message, disconnect and reconnect the device from the USB port again, 

or disconnect, close and restart the software and then plug in the device again. It should detect that a device 

was plugged in and then let you add it. 

 

Now the device shows up in the window on the left, under "Data Logger". Before you click the "Device 

Settings" button, you must click on the device name to highlight it. This is a step that is not intuitive, 

especially when the list of devices contains only one device, your sound level meter. After you click on the 

device name to highlight it (see screenshot below), start the setup as you did before by clicking the setup 

icon (the blue and white gear wheel): 
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If you still get the Setting Failed message, try a different USB port. On some computers, only the USB port 

that you initially plugged the device into works, and it has trouble connecting to it when a different port is 

used. But usually this should not be an issue. If no USB port works, check if the USB driver was installed 

correctly (see the next FAQ). 

 

 

Q: The software does not detect my sound level meter. What could be the problem? 

 

A: Check if Windows has properly initialized the sound level meter and installed the correct USB driver. In 

Windows 10, that driver is C:\Windows\System32\drivers\usbser.sys, which is a driver that comes with 

Windows 10 (not with the sound level meter software). If the sound meter is properly recognized, you 

should see it show up as a serial port in Device manager: 

 

 

 

(If you are unfamiliar with “Device Manager”, here is how you access it in Windows 10: Click the Windows 

Start button, then click on “Settings” and start typing “Device Manager” in the search box. Windows will 

suggest “Device Manager” above the search box, click on it to launch the app.):  

 

 

If you see an exclamation mark next to the device entry under “Ports”, then the driver has not been installed 

correctly. Try installing it manually by right-clicking on the device name inside Device Manager and 

selecting “Update driver” in the popup menu. Then browse and select 

C:\Windows\System32\drivers\usbser.sys as the driver for this device. 

If your computer is not running Windows 10: If you are running an older version of Windows, download 

the following driver and install it separately: https://ennologic.com/downloads/USBBridgeSetup_CA.zip. 

Unzip the downloaded file, then double click on USBBridgeSetup_CA.exe to run the installer. When asked 

to select the product type, choose “USB to UART Bridge” and click “Next”. Choose an installation directory 

(the default provided is usually fine), click “Next” and then “Install”. Click “Finish” to exit the setup. Plug 

in the sound level meter and check if the USB initialization succeeds. If Windows encounters a problem 

https://ennologic.com/downloads/USBBridgeSetup_CA.zip
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installing the “Holtek USB to UART Bridge” driver and says "A problem was encountered while attempting 

to add the driver to the store.", you need to disable Driver Signature Verification Enforcement on your 

computer since this driver is not digitally signed. To do that, please follow the instructions in this video: 

https://www.youtube.com/watch?v=71YAIw7_-kg. After you disabled driver signature enforcement, plug 

in the sound level meter again and this time the driver installation should succeed. Please note that these 

step should only be necessary in Windows versions other than Windows 10. 

 

 

Q: I’m struggling with the software. Everything looks right with the Data Graph, Data 

Summary, and Data List, but the Report tab is empty.  

 

A: This may be the result of an issue we had with software version 2020.11.10.0942. Please uninstall this 

version, reboot your computer, and install version 20200.8.18.1031 which is available on our website (see 

screenshot below). 

 

Q: How do I delete the data stored in the sound level meter? 

 

A: Data stored in the meter will be cleared when you set up the meter for a new recording session. 

 

 

Q: Will the meter lose its data when the battery runs out? 

 

A: No, the data is stored in non-volatile memory, which means it will not lose its data when the 9V battery 

runs out or (if powered through its USB port) USB power is removed. 

 

 

Q: I click the download button and the dialogue box never moves from 0%. What would 

resolve this? 

 

A: Make sure the noise level meter is powered on when you are downloading its data. If it's connected but 

turned off, you may see the download process getting stuck at 0%. 

https://www.youtube.com/watch?v=71YAIw7_-kg
https://ennologic.com/product/decibel-meter-and-recorder-es528l/
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Q: I cannot download data from my sound level meter. What troubleshooting steps can I try? 

 

A: 1. Make sure the data logger name is highlighted in the device list on the left before pressing the 

Download button. 

2. Make sure the data logger is turned on. 

3. Make sure you use the USB cable that came with the product. There are many Micro USB cables used by 

other products that can only be used for charging and not for data communications.  

4. Try using the same USB port that you used when setting up the data logger for the first time. 

5. If you installed the software on your C: drive, make sure the version is the latest version of the main 

release (currently Version 2020.08.18.1031) 

6. Launch Device Manager on your computer (Open Settings and search for Device Manager) and verify 

under "Ports (COM & LPT)" that the sound level meter is showing up as a "USB Serial Device (COMxx)". If 

you're using Windows 10, try updating the driver. If you're using older versions of Windows, re-install the 

"“USB to UART Bridge" driver as explained in the software manual.  

7. Uninstall the software, reboot your computer and reinstall it. 
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